Jeep Garage  - Jeep Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
The UConnect system in my 2015 Jeep Grand Cherokee started continuously rebooting this weekend. I see many previous posts from 2015 where folks experienced this indicated it was due to a failed over the air update but I can’t find a thread that talks about how the issue was actually resolved, and they all seem to say that a fix is planned in weeks. It’s now a few years later. Anyone else experiencing this or know how to fix it? I don’t have an image of the system on USB to restore it. When I navigate to the system settings before a reboot occurs, the option to restore to factory settings is grayed out. Thanks for any help you can provide.
 

·
Registered
Joined
·
5 Posts
I came here to research our problems with UConnect. Our Apple CarPlay is gone, tried different phone and different cables. I plug in our my phone, tired different cables, etc it just doesn't engage. I looked up on line how to do a soft reset and our GC does nothing. We've only had the car 5 months so I'm disappointed that something is going wrong already-hoping it's an easy fix, but I use the UConnect daily. I couldn't find anything here that talks about the same problem. Did you ever fix yours?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Unfortunately, I did not get the problem fully resolved, although it is partially resolved. After a few hours on the phone with Uconnect today, I was told I have to take the vehicle to the dealer to get the system wiped and reloaded. Eventually, after doing nothing, the system stopped rebooting. However, every time I would then turn the Jeep off, paired phones would disappear. And, even after pairing a phone, none of the media options (e.g., bluetooth via phone, SD card, USB card) would work; only the aux plug worked. And, sometimes, the entire radio freezes and I have to do a hard reboot to get it to work. I'm not sure if this will work for you, but they had me also try something else. However, before I share what they had me do, realize my my vehicle Uconnect system is pre-CarPlay, so I'm not sure if this will work. The "hard reboot" they had me try was to have the Jeep running, and then press the volume and turn buttons simultaneously until the system rebooted. The "soft reboot" option they had me try was to press and hold the green phone button and VR button on the steering wheel while the Jeep was running, holding them for over 60 seconds. Then, release the buttons, turn the Jeep off, and then open the driver door for over 60 seconds. After this, restart the car. This last option was supposed to reload the software from a burned image, but I don't think it worked. Good luck. This issue is enough to make me strongly consider moving to a vehicle without Uconnect.
 

·
Registered
Joined
·
5 Posts
I will try it all. I've already done some of it from an internet search and nothing worked. It was there one day and just gone the next when I plugged in to use Waze. I am updating my phone tonight to the latest iOS, but my daughter tried her phone with the latest and didn't work either. I'm also going to use her cable from her car which is working. This is so frustrating. I use Waze every day via uconnect.
 

·
Registered
Joined
·
5 Posts
I cannot explain this at all. As of this morning CarPlay wasn't working. This afternoon I got in the car and it worked again. Same phone, same cable, no explanation.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Glad you got it working. I solved my problem as well, although it took a few hours. On YouTube, I discovered a way to truly restore the Uconnect system to the original factory settings. After starting the Jeep and/or placing it in Run, you can press and hold the up and down temperature buttons simultaneously. After a few seconds, a new menu appears that is for the dealer to use. BE CAREFUL about what you do in this menu. There is an option to do a factory reset of the entire system. I did this; it took about 30 minutes with the Jeep running. Since this put the system back to its original configuration, I then had to reinstall the latest software update that I got from the Jeep site, using a USB stick. This took another 30-40 minutes. Since I also also previously installed a map update, I had to reinstall this update as well after the UConnect update, which took another 40 minutes. Once all of this was done, I synced up my phones, confirmed the USB and SD cards (both with music) could be read, and then shut everything down for 10 minutes. When I restarted the Jeep, all worked. I repeated this 3 times, and so far, so good -- all seems to be working. So, if you get to the last resort with no other options, a factory reset may work for you.
 

·
Registered
Joined
·
1 Posts
The UConnect system in my 2015 Jeep Grand Cherokee started continuously rebooting this weekend. I see many previous posts from 2015 where folks experienced this indicated it was due to a failed over the air update but I can’t find a thread that talks about how the issue was actually resolved, and they all seem to say that a fix is planned in weeks. It’s now a few years later. Anyone else experiencing this or know how to fix it? I don’t have an image of the system on USB to restore it. When I navigate to the system settings before a reboot occurs, the option to restore to factory settings is grayed out. Thanks for any help you can provide.
Had the same issue and even took my Jeep to the dealership only to be told I need a new $800 radio. I did some online research and found the instructions below. The main thing is you have to be on the schedule update screen for this to work. My reboot multiple time a day for a week before it said update failed. I then had to wait for the update screen to come back up to follow the instructions.
1. Choose 'Schedule Update' 2. Set time 2 minutes ahead of current time (for example, if it is currently 8:43 AM, set the time for 8:45 AM) 3. Once the time is chosen, select 'Set Time' 4. Select 'OK'. Do NOT press the X. 5. Wait for 3 minutes to allow the set time to pass (for example, if the time was set for 8:45 AM, wait until at least 8:48 AM) 6. Perform two button reset (Simultaneously press and hold the circular Browse/Enter & Power/Mute buttons) 7. Wait for 'Schedule Update' pop up to be shown again, but do NOT Set Time 8. Perform a complete sleep cycle a. Ignition off b. open door c. close door d. lock the door e. Wait for 10 minutes 9. Turn the Ignition On, and the pop ups should cease
 
1 - 8 of 8 Posts
Top