Jeep Garage  - Jeep Forum banner
1 - 18 of 18 Posts

· Registered
Overland
Joined
·
77 Posts
Discussion Starter · #1 ·
After many days with different browsers and computers of trying, The Uconnect site claims "Entered VIN is not valid. Please confirm." One week ago a call to Uconnect and it worked saying no updates as the rep. walked me through the site doing everything I have done a million times before. Just a fluke it worked. Another call to Uconnect three days ago I was told I have a valid VIN and Uconnect is very busy so keep trying. Anyone have issues like this?
 

· Premium Member
2017 Summit
Joined
·
8,661 Posts
Many people have that issue and many have posted about it. As a level 2 supporter of this site you could have already installed the update.

---
 

· Registered
Joined
·
183 Posts
Each time I go to the Uconnect website, type in my VIN, it says no updates available? Is this what alot of people are seeing? If I have the 8.4A (RA3), I think I can update to 13.19. Why does Uconnect not see that I have updates?
 

· Premium Member
2017 Summit
Joined
·
8,661 Posts
Each time I go to the Uconnect website, type in my VIN, it says no updates available? Is this what alot of people are seeing? If I have the 8.4A (RA3), I think I can update to 13.19. Why does Uconnect not see that I have updates?
I'm not sure if anybody has gotten that update from uConnect. Willx made it available here at Jeep Garage. They might not be ready for a wide release yet.


---
 

· Lifer: Old Geezer
Overland
Joined
·
4,607 Posts
After many days with different browsers and computers of trying, The Uconnect site claims "Entered VIN is not valid. Please confirm." One week ago a call to Uconnect and it worked saying no updates as the rep. walked me through the site doing everything I have done a million times before. Just a fluke it worked. Another call to Uconnect three days ago I was told I have a valid VIN and Uconnect is very busy so keep trying. Anyone have issues like this?
Yes.

Uconnect indicated "thank you for bringing this to our attention"

Now the excuse is "the site is very busy so keep trying", huh?


What are they running that site on, a Commodore-64?

Highly underwhelmed with their ability to do much of anything.
 

· Premium Member
Joined
·
4,849 Posts
Have you installed it yet?

Did it HELP?

Or did it make it worse.

Have the update downloaded, not sure I want to install it yet or not...
The update does not make anything worse. If you have a problem with you cell card in the radio it will report the issue to you that is all. I do not believe there is a single person here who would say it didn't improve things.
 

· Premium Member
2017 Summit
Joined
·
8,661 Posts
Since I got my Jeep the dealer changed the PCM and I did both updates and the tranny fix. Although the tranny was OK to start with, it did show me I had a very loose battery cable?

My only concerns now, not really problems, are;

>The system shuts down within 5 seconds of entering the car, instead of the one to three minutes it should take.

>The tailgate sometimes takes more than two clicks to open with the fob.

>The setting for navigation display in cluster turns off every few days, but never during use.

>The Select Terrain and QuadraLift don't interact the way they should.

The worst this all means to me, is having to press an extra button or two once in awhile. If all stays as it is, I will just get used to pressing the extra buttons rather than make a fuss about it.


---
 

· Premium Member
Joined
·
4,849 Posts
Since I got my Jeep the dealer changed the PCM and I did both updates and the tranny fix. Although the tranny was OK to start with, it did show me I had a very loose battery cable?

My only concerns now, not really problems, are;

>The system shuts down within 5 seconds of entering the car, instead of the one to three minutes it should take.

>The tailgate sometimes takes more than two clicks to open with the fob.

>The setting for navigation display in cluster turns off every few days, but never during use.

>The Select Terrain and QuadraLift don't interact the way they should.

The worst this all means to me, is having to press an extra button or two once in awhile. If all stays as it is, I will just get used to pressing the extra buttons rather than make a fuss about it.

---
Bill,

I am still going to look into your first issue. Got side tracked with my trailer tests. BTW, posted more mileages.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top