Jeep Garage  - Jeep Forum banner
1 - 8 of 8 Posts

·
Registered
Jeep GC Trailhawk
Joined
·
59 Posts
Discussion Starter · #1 · (Edited)
I have the UConnect 8.4 4C UAQ in my '18 GC Trailhawk. The uConnect firmware/software is current. Just now, I found that my backup camera doesn't work, my clock is not keeping time, and features like Forward Collision Warning also quit. Settings that seem related to the camera and clock cannot be set. A trip to the dealer is in order, but if there's a known fix or some kind of reset option, perhaps someone can share the info. Thanks!

Update: Well, the problem resolved on its own. After sitting for about 2 hours, the system returned to normal. I'd still be interested in learning whether stuff like this is common or perhaps yet another bug in the UConnect system.
 

·
Premium Member
Joined
·
2,441 Posts
I don't think it's common. If it happens again take pics and video.
 

·
Registered
Joined
·
2,073 Posts
I have the UConnect 8.4 4C UAQ in my '18 GC Trailhawk. The uConnect firmware/software is current. Just now, I found that my backup camera doesn't work, my clock is not keeping time, and features like Forward Collision Warning also quit. Settings that seem related to the camera and clock cannot be set. A trip to the dealer is in order, but if there's a known fix or some kind of reset option, perhaps someone can share the info. Thanks!

Update: Well, the problem resolved on its own. After sitting for about 2 hours, the system returned to normal. I'd still be interested in learning whether stuff like this is common or perhaps yet another bug in the UConnect system.
Please let us know how your dealer visit went. If you need the hard reset instructions in the future, here they are: go to Settings -> System Information -> Reset to Factory Default. Please be advised this will delete any saved information such as radio presets, Bluetooth pairings, etc.

Kori
Jeep Social Care Specialist
 

·
Registered
Jeep GC Trailhawk
Joined
·
59 Posts
Discussion Starter · #4 ·
Thanks, Kori. I didn't go to the dealer as the issue resolved spontaneously and has not recurred, and all of the systems seem to working normally since then. I was aware of the reset option, which would have been my next step before going to the dealer. As others have reported, I also suffered the known bug that caused the radio to lock up, and that also resolved on its own overnight. So, my assumption is that the UConnect system may present issues occasionally that may go away if the system is allowed to go dormant (vehicle powered off and out of range of the keyless entry fob) for a given amount of time.

In case it's helpful for tracking a possible bug, I had lost backup cam, forward collision warning, bluetooth, and all of the settings/options that would allow a user to make adjustments to the camera and collision/safety warnings. Either the settings were set to off/disable, or would immediately revert to my custom settings when I tried to change them. While I was in Reverse, the usual screens were available, instead of the backup cam being functional. Also,the clock froze and could not be set.
 

·
Premium Member
Joined
·
2,441 Posts
I wonder if it was finishing up an update.
 

·
Registered
Jeep GC Trailhawk
Joined
·
59 Posts
Discussion Starter · #6 ·
Not AFAIK. All previous updates were preceded by a notice and I had to approve them.
 

·
Registered
2018 WK2 HA
Joined
·
7 Posts
I am going to chime in here. My 18 HA did it last week, apparently, it was updating something in the background. Noticed some icons moved around a bit after, but all works well now.
 

·
Registered
Jeep GC Trailhawk
Joined
·
59 Posts
Discussion Starter · #8 ·
Mine came back entirely; nothing changed. Whether UConnect does any updates without notice and acceptance, I don't know for sure, but I know that I received notice a few times over the past months. Also, I'd question whether the system would be operable at all during an update, and my audio system was.
 
1 - 8 of 8 Posts
Top