Jeep Garage  - Jeep Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
451 Posts
Discussion Starter #1
On my 2018 WK2 with Uconnect 4c Nav, quite often (not always) with a US pllugged into the media center, I get an error message that tells me the USB "no media files found" or to "connect device". I unplug it and plug it right back in and it works fine, even picking up with the same track it was playing before. When it happens, it happens when I first start the vehicle, works fine until I turn the ignition off. Doesn't happen every time. Using a 32gb SanDisk cruiser UBS v2.0. Any help?
 

·
Registered
Joined
·
103 Posts
So I'm having the issue of it not finding my phone connected to USB, no rhyme or reason why. Took it to the dealership while it was happenings, my service guy couldn't get his iPhone to connect, car play didn't work, did connect device on the media.

Happens on an off, where all of a sudden I get into the car and Android auto doesn't work, only Bluetooth connection.

Dealership started a star case regarding the issue.
 

·
Registered
Joined
·
1,649 Posts
On my 2018 WK2 with Uconnect 4c Nav, quite often (not always) with a US pllugged into the media center, I get an error message that tells me the USB "no media files found" or to "connect device". I unplug it and plug it right back in and it works fine, even picking up with the same track it was playing before. When it happens, it happens when I first start the vehicle, works fine until I turn the ignition off. Doesn't happen every time. Using a 32gb SanDisk cruiser UBS v2.0. Any help?
Hello rich mac,

We're sorry to hear you're having such a hard time with your Uconnect system. Feel free to send us your VIN as we'd be glad to do some additional troubleshooting. If we can't help, I'll escalate your inquiry to our Uconnect Customer Care Team.

Jasmine
Jeep Social Care Specialist
 

·
Registered
Joined
·
1,649 Posts
So I'm having the issue of it not finding my phone connected to USB, no rhyme or reason why. Took it to the dealership while it was happenings, my service guy couldn't get his iPhone to connect, car play didn't work, did connect device on the media.

Happens on an off, where all of a sudden I get into the car and Android auto doesn't work, only Bluetooth connection.

Dealership started a star case regarding the issue.
Hi Zabes64,

We are sorry to hear that you are having concerns with your infotainment system in your Jeep. We are glad that you are currently working with your dealer to resolve this concern. If additional assistance is needed while your vehicle is in service, please message us.

Darlene
Jeep Social Care Specialist
 

·
Registered
Cherokee Trailhawk
Joined
·
371 Posts
I just picked up my new WK2, 2018 Sterling. I teased in my 2016 Cherokee Trailhawk and I am floored that my audio needs to be cranked to 33 or higher to hear anything off my iPhone.

If I accidentally switch over to radio I almost blow my windows out. My previous Jeeps dipped a little, maybe 2-4 units but having to turn up a premium sound 8.4 with Nav, Car Play is totally ridiculous. It’s the same with Bluetooth or usb corded in either port.

Any help would be nice.
 

·
Registered
Joined
·
122 Posts
I have exactly the same problem as the OP's on my 18. I use a 32 GB SanDisk Ultra Fit USB 3.0. The volume output issues with my iPhone are similar to champagneinhand's as well. Nothing similar happened with my previous GC's. Hopefully this is a simple software issue that can be addressed in future firmware updates.

 

·
Registered
2018 WK2 Altitude
Joined
·
138 Posts
I also have the same problem on my '18 Altitude as original poster. I have a 64gb Sandisk Ultra Fit (or similar) and I've probably had to unplug and plug back in my USB stick with my music on it 5 or 6 times since I've owned my jeep (bought last December). When I plug it back in, it remembers what I last was listening too.
 

·
Registered
Cherokee Trailhawk
Joined
·
371 Posts
I also have the same problem on my '18 Altitude as original poster. I have a 64gb Sandisk Ultra Fit (or similar) and I've probably had to unplug and plug back in my USB stick with my music on it 5 or 6 times since I've owned my jeep (bought last December). When I plug it back in, it remembers what I last was listening too.


How do you guys get your CDs or music collections to copy onto thumb drives correctly? I can’t get my MacBook Pro to do anything but burn them to CDs.

With the CarPlay issue I have no access to my large music collection and while SiriusXM is fine, I have loads of favorites just sitting in my phone, tablet and computer. I would at least like to try and use a USB even if it cuts out now and again.
 

·
Registered
2018 WK2 Altitude
Joined
·
138 Posts
How do you guys get your CDs or music collections to copy onto thumb drives correctly? I can’t get my MacBook Pro to do anything but burn them to CDs.
Are you using itunes? You need to most likely use alternative programs to rip the CD's into MP3's. There are a ton out there, just google search "how to rip CD's to MP3 mac" on google and you will see options. It's been a while since I've owned a mac, but I remember downloading some pretty decent programs to rip music from CD to MP3 or convert from one format to another. I don't think it's very easy to convert an itunes purchased music title to an mp3 format and may violate some of apples policies, but lots of alternatives.

Here is a source article on a few alternatives:
https://www.macworld.co.uk/feature/mac-software/best-alternatives-itunes-for-ripping-cds-mp3-3659456/

You also need to make sure your USB stick is formatted in the right file format. I believe it's NTFS, which Mac should handle. If not, there is an app for that too! :)
 

·
Registered
Joined
·
122 Posts
Hey champagneinhand I hadn't realized your iphone sound levels were that bad with the uconnect unit. I do have sound level issues when using carplay or BT but it's still good quality albeit not as loud as USB or radio can be. Sorry about your issues, I hope that either FCA or uconnect can address all these issues.
 

·
Registered
Cherokee Trailhawk
Joined
·
371 Posts
Hey champagneinhand I hadn't realized your iphone sound levels were that bad with the uconnect unit. I do have sound level issues when using carplay or BT but it's still good quality albeit not as loud as USB or radio can be. Sorry about your issues, I hope that either FCA or uconnect can address all these issues.


I did get the situation sorted where volume is much better, but still not what I had expected. I’m going to try to burn everything I have into MPEG or the best available format on USB.

I probably will do some speaker replacement as well as I don’t think the center speaker is very good even in the premium package. I have a few test songs in various genres that failed pretty miserably. But at least I can hear them now.
 

·
Registered
Joined
·
1,649 Posts
@JeepCares Any updates on this issue?
Hi nvfusa,

We're sorry to hear that you are still experiencing this concern. If you have not done so already, please send us a private message with your VIN and mileage so that we can have the Uconnect Team trouble shoot with you.

Darlene
Jeep Social Care Specialist
 

·
Registered
Joined
·
6 Posts
Having the same issue with 2108 Grand Cherokee. USB port doesn't recognize my device, Ipod or Iphone....


Pretty frustrating that I've had the car for a week and I'm going to have to take it in for service already.
 

·
Registered
Grand Cherokee
Joined
·
3,129 Posts
I was having the same problem with my aftermarket head unit. Turned out to be the USB cable between the head unit and the phone. It worked fine for a while then I started to get the warning message about "USB media file not available" "USB Error", etc. Even when the phone was not plugged in, just the empty cable.

New cable and it works perfectly.

Keep in mind, USB is not that all that universal, there are USB cables just for charging, there are USB 1, 1.1, 2.0, 3.0. And the cables are delicate and can get damaged just from a kink or turn too tight in it, which is what happened to mine.
 

·
Premium Member
Joined
·
146 Posts
Hey Gang,

This post is from 2018 but I wanted to bring it back up.

I have been experiencing the same issue as the original poster (rich mac). In the beginning it was very intermittent - maybe 3 or 4 times in the past year - and I did not think much of it. It has now happened twice in 2 weeks and I am starting to get concerned. I have a 2018 WK2 Limited with the Lux II package and have all my tunes stored on a USB drive. When I first start the vehicle the media center displays the message "..media files not found....connect device...". If I disconnect the USB and reinsert it into the same port it picks back up in the middle of the song that was playing when the vehicle was last shut down.

- JeepCares - Has the UConnect Team been able to trouble shoot the issue?

- rich mac & nvfusa - Were you able to get this resolved?

My thanks for any advice the Jeep Garage community and Jeep Cares can provide.

Bob.
 

·
Registered
Joined
·
6 Posts
I'm stilling having the same issue. I finally took it in to have service check it out. The mechanic/tech working on it acknowledge the issue/problem. Then I got a call from the service director who told me they can't fix it and just use Apple CarPlay..."that what it's for". Stopped going to that dealer for service and will never go back to buy another car (that would be Brunswick Auto Mart, Brunswick, Ohio). This was my second Jeep purchase from them....
 

·
Premium Member
Joined
·
146 Posts
Thanks for your reply Mikemel10. I'm sorry to hear the issue was not resolved. That is a ridiculous answer from the dealer. I don't know how some of these service departments stay in business. They must make a fortune off warranty repairs because no one would voluntarily go there and pay for service.
 

·
Registered
Joined
·
1,649 Posts
Hey Gang,

This post is from 2018 but I wanted to bring it back up.

I have been experiencing the same issue as the original poster (rich mac). In the beginning it was very intermittent - maybe 3 or 4 times in the past year - and I did not think much of it. It has now happened twice in 2 weeks and I am starting to get concerned. I have a 2018 WK2 Limited with the Lux II package and have all my tunes stored on a USB drive. When I first start the vehicle the media center displays the message "..media files not found....connect device...". If I disconnect the USB and reinsert it into the same port it picks back up in the middle of the song that was playing when the vehicle was last shut down.

- JeepCares - Has the UConnect Team been able to trouble shoot the issue?

- rich mac & nvfusa - Were you able to get this resolved?

My thanks for any advice the Jeep Garage community and Jeep Cares can provide.

Bob.
I'm stilling having the same issue. I finally took it in to have service check it out. The mechanic/tech working on it acknowledge the issue/problem. Then I got a call from the service director who told me they can't fix it and just use Apple CarPlay..."that what it's for". Stopped going to that dealer for service and will never go back to buy another car (that would be Brunswick Auto Mart, Brunswick, Ohio). This was my second Jeep purchase from them....
Hi,
I'm sorry to hear you're experiencing these concerns. Please let me know if you plan on visiting a different dealership for this concern. I would be happy to open a case for you.

Alison
JeepCares
 
1 - 20 of 25 Posts
Top