Jeep Garage  - Jeep Forum banner
1 - 20 of 82 Posts

· Registered
2021 Jeep Grand Cherokee L Summit
Joined
·
918 Posts
Discussion Starter · #1 ·
Anyone see this? I was checking my charging voltage after starting it for the first time in over a month.
Voltage was 12.5 before starting, dropped to 12.2 while cranking (according to that screen).
Started just fine. Voltage peaked at 14.5 for a good while, then eventually dropped to about 14.2 after an hour. Also about an hour of driving the Start/Stop started working again, which is typical for me since I rarely drive it
But, anyway, NO OIL PRESSURE which is obviously wrong, it wouldn't last 10 minutes I'd bet!
I did check the gauges in the main cluster (screen 2 maybe, then left/right until they showed up) and it was something like 32 PSI at idle, which is perfect to me.
(Bonus points for those bothering to figure out where I was when I took that pic)
Font Audio equipment Technology Speedometer Electronic device
 

· Registered
2021 Jeep Grand Cherokee L Summit
Joined
·
918 Posts
Discussion Starter · #3 ·
My '22 Trailhawk also has non functioning oil pressure on off road page.
Odd thing is I swear it was working months ago, eh, maybe not. I guess I need to at least complain about it. Maybe they'll do some update at some point.
 

· Registered
2022 Jeep Grand Cherokee L Summit Reserve 4x4 5.7L
Joined
·
315 Posts
My guess on where you were when you took the pic…. In your car! Lol
 
  • Haha
Reactions: Pioneer4x4

· Registered
Joined
·
7 Posts
Anyone see this? I was checking my charging voltage after starting it for the first time in over a month.
Voltage was 12.5 before starting, dropped to 12.2 while cranking (according to that screen).
Started just fine. Voltage peaked at 14.5 for a good while, then eventually dropped to about 14.2 after an hour. Also about an hour of driving the Start/Stop started working again, which is typical for me since I rarely drive it
But, anyway, NO OIL PRESSURE which is obviously wrong, it wouldn't last 10 minutes I'd bet!
I did check the gauges in the main cluster (screen 2 maybe, then left/right until they showed up) and it was something like 32 PSI at idle, which is perfect to me.
(Bonus points for those bothering to figure out where I was when I took that pic)
View attachment 245692
mine is doing the same thing it was working fine till the other day exact same issue
 

· Registered
2021 Jeep Grand Cherokee L Summit
Joined
·
918 Posts
Discussion Starter · #8 ·
Hmm, odd. I don't think I got any update, mine has sat for over a month before this.
 

· Registered
2022 Jeep Grand Cherokee L Summit Reserve 4x4 5.7L
Joined
·
315 Posts
Mine also shows 0 oil pressure. Definitely a recent change.
 

· Registered
Joined
·
559 Posts
Definitely software. You can pull up the exact same 5 gages in the cluster at the same time as the offroad pages. All the readings match and the cluster displays the oil pressure reading while the offroad pages is at zero.
 

· Registered
Joined
·
5,382 Posts
I'm gonna have to check my off road page now.
As mentioned its just about certain its a software issue.

If for some reason it can't find the oil psi information maybe due to a SW timing issue the least it could do is display N/A instead of 0 psi.
 

· Registered
2021 Jeep Grand Cherokee L Summit
Joined
·
918 Posts
Discussion Starter · #16 ·
...
If for some reason it can't find the oil psi information maybe due to a SW timing issue the least it could do is display N/A instead of 0 psi.
It shows "-- psi"
Look at the pic in my first post.
 

· Premium Member
Joined
·
1,672 Posts
-- is probably signifying that is has no input; as a geek that's more what I'd expect than N/A.

At any rate, my late-september build WL75 does the same thing.
 

· Registered
2021 Jeep Grand Cherokee L Summit
Joined
·
918 Posts
Discussion Starter · #20 ·
So, does ANYBODY, have one that works?
 
1 - 20 of 82 Posts
Top