Jeep Garage  - Jeep Forum banner
1 - 20 of 20 Posts

· Registered
22 WL74 Overland
Joined
·
155 Posts
Discussion Starter · #1 ·
22 2 row Overland. 10.1 Uconnect 5. Most of the time i can't even get Android Auto to connect wirelessly. When it does it will work for a while then disconnect and not work again. I have a Samsung S22 Ultra. It won't work with my Samsung Note9 either. When it is wired it will work for a while then disconnect and might start working again but sometimes it won't. The dealer did a update. Didn't change a thing. Now they are ordering a new radio but say 5 to 6 weeks to get it. Anyone have the same problem? Any fix?
 

· Registered
Joined
·
518 Posts
Wireless Android Auto w my Pixel 6 is flaky for the first few minutes, then is pretty solid. Google Maps will wrestle w Factory Nav occasionally, w Google grabbing screen from Factory Nav.

I bought a 6in USB C cable and will connect my Pixel if things are acting wonky. Hoping a uConnect update will improve things (in can hope anyway).

Overall, it's working fine, but could be more consistent.
 

· Registered
Joined
·
18 Posts
22 2 row Overland. 10.1 Uconnect 5. Most of the time i can't even get Android Auto to connect wirelessly. When it does it will work for a while then disconnect and not work again. I have a Samsung S22 Ultra. It won't work with my Samsung Note9 either. When it is wired it will work for a while then disconnect and might start working again but sometimes it won't. The dealer did a update. Didn't change a thing. Now they are ordering a new radio but say 5 to 6 weeks to get it. Anyone have the same problem? Any fix?
I have a 22 WKL SR. Same issue. My fix is to connect it via cable. Otherwise it either won't connect or it constantly disconnects and the notification screen pops up telling me it's not connected which is very annoying - especially when I'm using Android for navigation. The dealership said to bring it in but so far I haven't heard of anyone finding a fix (new radio, update software, etc) and I don't want to be without my vehicle for that long. Hopefully somebody on here is able to figure out the answer. I did a review on the Android Auto app in GooglePlay. Tried all the suggested fixes with no success :(
 

· Registered
22 WL74 Overland
Joined
·
155 Posts
Discussion Starter · #6 ·
diagnosis was about 2 hours before they decided to replace the radio. They said that is the next step in diagnosing it. Ask for a loaner. They will say they dont have one. Tell them you will wait for one to be available and make an appointment when a loaner is available.
 

· Registered
22 WL74 Overland
Joined
·
155 Posts
Discussion Starter · #7 ·
Android auto connects through Bluetooth correct? Alexa works fine on it and can do everything android auto can do. UConnect also works fine. It is a little bit more limited than Alexa. Still Android Auto should work so They still have to fix it. If Alexa and UConnect work fine then it has to be something with the Jeep software doesn't it? They want to replace the radio at the dealership. Im thinking that there is nothing wrong with the hardware.
 

· Administrator
Joined
·
11,955 Posts
Android auto connects through Bluetooth correct?
Not exactly. Wireless AndroidAuto and CarPlay both use BT for "setup" of the connection, but everything is then passed off to a private short distance WiFi network. BT does not have the bandwidth to support these two technologies for both media and screen mirroring.
 
  • Like
Reactions: Ang29

· Registered
22 WL74 Overland
Joined
·
155 Posts
Discussion Starter · #9 ·
i thought so. When i 1st got the jeep it showed a new wifi network but wouldnt let me connect to it. said i needed a pass word. i remember with my Silverado it was a open wifi network.
 

· Administrator
Joined
·
11,955 Posts
Wireless AndroidAuto/CarPlay local private WiFI is usually only accessible by the one device that connects via it after registration. It's a big reason why folks find they cannot usually provide hotspot services to their kiddos via their phone if they are using wireless AA/CP. Kind of a "pick your poison" situation. Personally, I prefer wired CarPlay...
 

· Registered
Joined
·
18 Posts
22 2 row Overland. 10.1 Uconnect 5. Most of the time i can't even get Android Auto to connect wirelessly. When it does it will work for a while then disconnect and not work again. I have a Samsung S22 Ultra. It won't work with my Samsung Note9 either. When it is wired it will work for a while then disconnect and might start working again but sometimes it won't. The dealer did a update. Didn't change a thing. Now they are ordering a new radio but say 5 to 6 weeks to get it. Anyone have the same problem? Any fix?
I have a 22 JGC L SR. I have been to the dealership three times for the same problem you are having. Service manager even tried connecting wirelessly with his Apple phone...no go. Recently I hit a deer and my baby has been in the shop for 2-1/2 weeks. I'm driving a 22 Dodge Ram 1500 from the rental company with UConnect and Android Auto. Once I paired my phone it has connected wirelessly EVERY TIME and it DOES NOT DROP! EVER. So what's the difference? Frustrated. Hate being tired to the cable.
 

· Registered
22 WL74 Overland
Joined
·
155 Posts
Discussion Starter · #13 ·
Yep the wifi direct keeps shutting off then back on on the jeep. Dealer said they will not replace the radio until after the next update. They said the update should be out by the end of the year. So basically they will not fix it this year. I bet it's hardware. If it was software it would be fixed by now.
 

· Registered
Joined
·
558 Posts
If it were software, I'd think we'd all have the issue. I do not. I use wireless carplay every single time I get in the car and haven't had any issues. I'd bet hardware as well, or a physical electrical issue (like my guess of Sarge's multitude of issues).
 

· Registered
Joined
·
18 Posts
If it were software, I'd think we'd all have the issue. I do not. I use wireless carplay every single time I get in the car and haven't had any issues. I'd bet hardware as well, or a physical electrical issue (like my guess of Sarge's multitude of issues).
So do all affected vehicles have similar build dates? Mine was February 2022 as I ordered it custom.
 

· Registered
Joined
·
1 Posts
Joining to say I have the exact same issue, 21 WL GC L. I can't even JUST use bluetooth for calls because it constantly disconnects the phone. Ive found if (and when) it lets you edit the settings on the phone, if you switch it to 'enable bluetooth' instead of 'enable android auto' and then tap on the icons for both phone and music when the phone connects, then the issue goes away entirely.............. until the next time you plug in with a cable to use AA. Then it changes that setting and you're screwed all over again.
 
1 - 20 of 20 Posts
Top