Jeep Garage  - Jeep Forum banner
61 - 80 of 142 Posts

·
Registered
Joined
·
1 Posts
Believe it or not, I found that if you get up around 8:00 am est. and perform the update, it will finish the process. Try it
 

·
Registered
Joined
·
1 Posts
I experienced the same issue and the reason it worked for one person "driving around for a few miles" is because steps 11-15 require a stable data connection. There OTA (over the air) updates not included in the update that you use via the USB Drive. So... if your update is failing at step 11 with regards to the wireless card or Sierra error, get in your jeep and drive to a different area with better signal. Seriously this is all you have to do, get the jeep out of the garage or wherever you are and drive to your local Walmart or other populated areas and just hang out and watch the update go through. Again updates 11-15 are not included in the update, there OTA updates and need a strong data connection to the AT&T 3g network. This is also the reason it most likely works and goes through at the dealership because there usually placed in populated areas of the town / cities of course. Again just drive to somewhere else and the update will go through, no need for all this crazy disconnect battery and constantly trying the update over and over. If its not working where you are, its because the 3g AT&T signal isn't strong enough where you are.
I experienced the same issue and the reason it worked for one person "driving around for a few miles" is because steps 11-15 require a stable data connection. There OTA (over the air) updates not included in the update that you use via the USB Drive. So... if your update is failing at step 11 with regards to the wireless card or Sierra error, get in your jeep and drive to a different area with better signal. Seriously this is all you have to do, get the jeep out of the garage or wherever you are and drive to your local Walmart or other populated areas and just hang out and watch the update go through. Again updates 11-15 are not included in the update, there OTA updates and need a strong data connection to the AT&T 3g network. This is also the reason it most likely works and goes through at the dealership because there usually placed in populated areas of the town / cities of course. Again just drive to somewhere else and the update will go through, no need for all this crazy disconnect battery and constantly trying the update over and over. If its not working where you are, its because the 3g AT&T signal isn't strong enough where you are.
I just bought my Cherokee yesterday and attempted to update via usb. I to am getting stuck at unit 11 not going through. How do I know if I have a strong 3G connection if I cannot see it? How do I know if that was even activated? I have tried almost all suggestions so far and am currently driving around where I know I get a strong signal on my phone but that is T-Mobile. I have never used AT&T before so do not have an account with them.
 

·
Registered
Joined
·
1 Posts
So I have the same issue I have a 2016 trailhawk and this is the first fourm I found with the same issue 100%. The dealers aren't open right now because of corona except for 2 or 3 weeks out. Did you ever resolve this? I have been trying all day
 

·
Registered
Joined
·
4 Posts
Contact Uconnect support team? Yes, they told me to take to dealer, and dealer told me it is out of warranty and bricked. That took all of 5 minutes. They didn't offer to help whatsoever and simply said once you get to that step you need a new unit.

What I'm confused with on your statement above is you "just continued to try to update and finally it worked." If you get to the step 11 situation, the unit can't be turned off anymore and continues all night rebooting until you pull negative battery cable and/or unplug power to back of unit. My unit is now unplugged from the rear via 52 pin connector and I have a new UAQ unit arriving in a couple of days. Wonderful expense for a USB update to brick a stereo that controls half of the Jeeps features. My wife loves it when the AC doesn't work or can be controlled. Great! :slapfight:
This is still an issue even today.
 

·
Registered
Joined
·
1 Posts
I was having the same issue in my 2016 Grand Cherokee and I just updated mine this week. I tried 5 times to do it just sitting in the driveway and kept getting the failed attempts on step 11. I tried all the fixes to get back to the previous version (hard reset, pulling the usb at step 1, etc.) and nothing worked. I decided to just go drive around since that had worked for some people and I don't think that I have really strong signal at my house either. I started driving when it was at step 6 and after about 10 mins of driving it was already on step 12 and it completed the update. I would recommend driving around if you haven't tried it already. The update also fixed the phone service issue and the delayed startup after starting the car.
 

·
Registered
Joined
·
4 Posts
I was having the same issue in my 2016 Grand Cherokee and I just updated mine this week. I tried 5 times to do it just sitting in the driveway and kept getting the failed attempts on step 11. I tried all the fixes to get back to the previous version (hard reset, pulling the usb at step 1, etc.) and nothing worked. I decided to just go drive around since that had worked for some people and I don't think that I have really strong signal at my house either. I started driving when it was at step 6 and after about 10 mins of driving it was already on step 12 and it completed the update. I would recommend driving around if you haven't tried it already. The update also fixed the phone service issue and the delayed startup after starting the car.
Consider yourself lucky then. I drove around for almost a month, having to “trick” my upgrade loop into turning off at 1% of the 3rd Unit every time I wanted the car to turn off once I got home. We had to have the radio replaced by the dealership, which was recommended by Uconnect and the dealership. Currently we are waiting on a final response from Uconnect on our issue. We will soon be at a 2 month resolution time frame as we’ve had difficulty with Uconnect fulfilling what they say they will do for us.
 

·
Registered
Joined
·
9 Posts
I have been driving around with the loop of death for a week now. Wasted my time with UConnect, they referred me to the dealer, dealer spent 20 minutes doing diagnostics and said they unhooked the battery, said there is nothing they can do and I need a new radio. New radio is $2,600, reconditioned is $600 plus labor. Really wish I never would have attempted the update, but I was not aware of any of this before I did. Can't believe Jeep and UConnect haven't found a solution to this after 2 years of loyal customer suffering. I have my 2014 JGC Limited back now, and so far it is still starting every day. Hopefully I will get the reconditioned radio installed sometime next week. Oh, and there is apparently no warranty on the reconditioned radio so I hope I am not throwing away $750 when this is over.
 

·
Registered
Joined
·
4 Posts
I have been driving around with the loop of death for a week now. Wasted my time with UConnect, they referred me to the dealer, dealer spent 20 minutes doing diagnostics and said they unhooked the battery, said there is nothing they can do and I need a new radio. New radio is $2,600, reconditioned is $600 plus labor. Really wish I never would have attempted the update, but I was not aware of any of this before I did. Can't believe Jeep and UConnect haven't found a solution to this after 2 years of loyal customer suffering. I have my 2014 JGC Limited back now, and so far it is still starting every day. Hopefully I will get the reconditioned radio installed sometime next week. Oh, and there is apparently no warranty on the reconditioned radio so I hope I am not throwing away $750 when this is over.
I COMPLETELY understand. We supposedly have a resolution with Uconnect after a month of driving it around in the loop. Had the radio replaced and now everything works but it was all because of the download attempt. That completely screwed up the car. I also agree that this issue should have been a recall issue. But it’s impossible to get anywhere with Uconnect. You can get front line employees on their phone system, but forget getting ahold of ANYONE in authority above them. Now that we have paid for the replacement, we are weeks into waiting for our Uconnect resolution. Who runs this company? If you’d like to waste an evening, go online and try to look up their corporate personnel to try to help you resolve your issue! They are well insulated. I couldn’t find a name of anyone anywhere. This was our 2nd Jeep purchase. We’ve been Jeep drivers for 20yrs. It’s quite disappointing.
 

·
Registered
Joined
·
1 Posts
Hello All,

Vehicle:
- 2016 Dodge Charger SXT Blacktop

Had the same issue everyone else reported here. I did the same and drove around to all kinds of areas (even under cell towers for work).
Went for the update because the system would lose 3G conn and the Nav was completely off.

I did see that someone on another page stated that if you pull the USB stick at ISO validation it would reset. (never got a chance test.)

The damn update only completed once i stopped at a Autozone for an unrelated visit. Not sure if that assisted but I did see that there were several carrier repeaters in this store.

I might have gotten lucky!!!
 

·
Registered
Joined
·
4 Posts
Hello All,

Vehicle:
- 2016 Dodge Charger SXT Blacktop

Had the same issue everyone else reported here. I did the same and drove around to all kinds of areas (even under cell towers for work).
Went for the update because the system would lose 3G conn and the Nav was completely off.

I did see that someone on another page stated that if you pull the USB stick at ISO validation it would reset. (never got a chance test.)

The damn update only completed once i stopped at a Autozone for an unrelated visit. Not sure if that assisted but I did see that there were several carrier repeaters in this store.

I might have gotten lucky!!!
My opinion... You got lucky!!!! We drove around for 2 months without radio while ATTEMPTING to work with Uconnect because when we started our quest with this radio loop, Uconnect told us this was their fault and it shouldn’t cost us a dime. After 2 month of constant check ins BY US, they finally agreed to reimburse us after WE paid for a replacement radio. Our dealership had contact with our Uconnect representative but it was a complete nightmare when a large company tells you over and over that they will send you info, or get approval from someone in their company (that they will not give you contact info to). I’ve never encountered a large company that will not allow you to speak with someone in authority above these front line customer service employees. Finally we were reimbursed, but our next car will NOT have the same system.
 

·
Registered
Joined
·
1 Posts
Boy I wish I saw this thread before I attempted to do a software update today. I've been having issues with the Uconnect sometimes deciding not to start when I start the car and at some point during the drive it would decide to come on. While it was off at some point it will decide to turn the heater on full blast and all the defrosters on. However i'm able to shut off the climate control with the physical "OFF" button the rear defroster stays on while the screen is blank. At some point randomly it would start up just as if I just turned on the car and it would be fine. I was also experiencing similar issues others stated here as well. Such as the pop up saying vehicle phone needs servicing and the Navigation is usually wrong as to where I am (not that I use it much anymore, i prefer my phone). Anyways the not starting up randomly was the most annoying issue especially on a very hot day. I pondered about replacing the unit but since it still worked most of the time I put it off. Today I decided maybe i'd try to update the software, BIG MISTAKE. I'm in the same boat now, neverending loop, I disconnected my battery for the night. It seems now i'm forced to buy a replacement unit. I've tried many "solutions" to get it working again like pulling the USB when it's on unit 2 preparing the ISO. It didn't work. '14 EcoDiesel with 102k miles
 

·
Registered
Joined
·
2 Posts
Hello! New member here, first post. Looking for any help. I am haveing the same issue as many. My 2016 Jeep Cherokee Update to 17.43.01 hangs at Unit 11 - Embedded air card. Sticks at 1%, Gives bolo software failure message.

I also had the phone service message. I have tried update several times now! Tried removing usb trick. Still Stuck in loop. On the phone with Uconnect Support, but no help. They did assign me a case number, but beyond that were not very helpful. AT this point I would just like to get the radio and screen back.
I have been reading threads and It seems this is very common issue. Can anyone provide more help or tips?
Hello, was your issue ever fixed? I am having the same exact issue and at this point I just want my radio back :(((((
 

·
Registered
Joined
·
2 Posts
Similar issue, uconnect had to be replaced unfortunately. No issues and no phone requires service nonsense anymore. You can PM me and I can assist with the steps I took.
Hello, can you please tell me the steps you took, i an having the same issue. The dealer is saying I need a new radio. Which is odd my radio was perfectly fine (aside from a 911 error message) until I attempted this update. At this point I’ll deal with the message!
 

·
Registered
Joined
·
3 Posts
After a few days scouring the forums and reading what you guys have been going through I was filled with dread! But I was able to get mine up and running again I hope this helps.

After leaving my Jeep's battery disconnected for 2 days and trying to run the update it just continued to fail as it had been doing for the past 3 days since it first started telling me that the vehicle phone requires service. I have tried the factory reset and the engineering menu factory reset with no improvement. I was just about ready to pack the thing up and send it in for repair because I figured that would be cheaper than going to the dealer since mine is a 2014 and out of warranty at this point. I decided that i was going to crack the thing open and take a look inside to see if the problem was something obvious.

I got myself a set of precision torx screwdrivers and then proceeded to open the thing up, you only need to remove 4 screws and then gently separate the two halves. Inside the unit there are two blocks of pins connecting each half together along with an antenna cable about 4" long. Anyways after putting it back together it started working again! So that makes me think that the problem with these units is just a little bit of corrosion between the pins so taking it apart and reseating it can do the trick or at least it worked for me! It must be a modern version of a really expensive NES cart.
 

·
Registered
Joined
·
1 Posts
228023
Can someone please help me. I got a 2016 Dodge Charger sxt. Mysoftware was out of date and also i couldn’t get my navigation to recalibrate so I’ve decided to update my software.everything was going smooth and good til this sh!% got stuck at 67% I’m like wtf!!! I tried like 20 times no luck!! I did research afterwards thinking damn I should’ve left this mf alone. Dodge count yo mf days!!! At this point idc about the update I just want my radio back. I tried different methods like taking out the usb at 1-3% no luck I tried taking the battery off no luck. Just this stupid loop that won’t go away. If anyone can help me or got any suggestions I would greatly appreciate it.
 

·
Registered
Joined
·
475 Posts
View attachment 228023 Can someone please help me. I got a 2016 Dodge Charger sxt. Mysoftware was out of date and also i couldn’t get my navigation to recalibrate so I’ve decided to update my software.everything was going smooth and good til this sh!% got stuck at 67% I’m like wtf!!! I tried like 20 times no luck!! I did research afterwards thinking damn I should’ve left this mf alone. Dodge count yo mf days!!! At this point idc about the update I just want my radio back. I tried different methods like taking out the usb at 1-3% no luck I tried taking the battery off no luck. Just this stupid loop that won’t go away. If anyone can help me or got any suggestions I would greatly appreciate it.
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
3 Posts
View attachment 228023 Can someone please help me. I got a 2016 Dodge Charger sxt. Mysoftware was out of date and also i couldn’t get my navigation to recalibrate so I’ve decided to update my software.everything was going smooth and good til this sh!% got stuck at 67% I’m like wtf!!! I tried like 20 times no luck!! I did research afterwards thinking damn I should’ve left this mf alone. Dodge count yo mf days!!! At this point idc about the update I just want my radio back. I tried different methods like taking out the usb at 1-3% no luck I tried taking the battery off no luck. Just this stupid loop that won’t go away. If anyone can help me or got any suggestions I would greatly appreciate it.
If yours is anything like the one that is in my jeep and isn't under warranty if you pop the back off and then put it back to reseat the pins inside that might help. That's all did and mine updated, even the cellular and GPS started working again and is still working.
 

·
Registered
Joined
·
1 Posts
View attachment 228023 Can someone please help me. I got a 2016 Dodge Charger sxt. Mysoftware was out of date and also i couldn’t get my navigation to recalibrate so I’ve decided to update my software.everything was going smooth and good til this sh!% got stuck at 67% I’m like wtf!!! I tried like 20 times no luck!! I did research afterwards thinking damn I should’ve left this mf alone. Dodge count yo mf days!!! At this point idc about the update I just want my radio back. I tried different methods like taking out the usb at 1-3% no luck I tried taking the battery off no luck. Just this stupid loop that won’t go away. If anyone can help me or got any suggestions I would greatly appreciate it.
I have a 2015 Jeep Grand Cherokee SRT. My uconnect update failed just like so many on this thread. I went to the dealer and talked to uconnect. Both said I will need a new system. Then, I found this thread. A couple of people discovered that if you drive around while doing the update it may eventually work. It took me two tries while driving and IT FINALLY WORKED!!!!!!! So I recommend following the uconnect recommended steps for updating but drive around on streets with an unobstructed view of the sky (satellites are used in the update I guess). Dealers will ask for a $125+ diagnostic fee just to tell you it is broken. If your uconnect is working with only minor issues (like occasionally rebooting on the road) I would not do the update. Finally, Uconnect and and Jeep both said they probably could get me a new unit for free since it was uconnect that made the recommendation to update and the system was working great prior to the updating process. I hope this helps........It was a happy day when I got mine to update. I celebrated the rest of the day with adult beverages on the beach.:)
 

·
Registered
Joined
·
475 Posts
I have a 2015 Jeep Grand Cherokee SRT. My uconnect update failed just like so many on this thread. I went to the dealer and talked to uconnect. Both said I will need a new system. Then, I found this thread. A couple of people discovered that if you drive around while doing the update it may eventually work. It took me two tries while driving and IT FINALLY WORKED!!!!!!! So I recommend following the uconnect recommended steps for updating but drive around on streets with an unobstructed view of the sky (satellites are used in the update I guess). Dealers will ask for a $125+ diagnostic fee just to tell you it is broken. If your uconnect is working with only minor issues (like occasionally rebooting on the road) I would not do the update. Finally, Uconnect and and Jeep both said they probably could get me a new unit for free since it was uconnect that made the recommendation to update and the system was working great prior to the updating process. I hope this helps........It was a happy day when I got mine to update. I celebrated the rest of the day with adult beverages on the beach.:)
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
9 Posts
I finally ended up buying the reconditioned radio last spring for $750 or so. Everything has been fine since. It sounds like it's a pretty simple fix to the radio, but dealerships don't take radios apart, they just send them in for reconditioning and then overcharge for them. Pretty good racket Uconnect and Mopar have going.
 
61 - 80 of 142 Posts
Top